WordPress 4.5: Solucionando los principales errores al actualizar

wordpress

Ayer por la tarde wordpress.org lanzo la actualización a WordPress 4.5, y como siempre que se produce una actualización mayor, hay mucha gente que esta teniendo problemas después de haber realizado el proceso.

En WordPress 4.5 tenemos unos cambios bastante importantes que pueden afectar al uso de este CMS si no “arreglamos” unas cuantas cosas antes.

Solucionando los principales errores al actualizar a WordPress 4.5: cuidado con la cache

Siempre es una buena práctica borrar todas las caches de tu ordenador y de tu servidor cuando se actualiza WordPress, pero en esta actualización esto hay que hacerlo si o si o vamos a tener muchos problemas.

Vamos a repasar que tipo de caches podemos tener:

  • Plugin cache: como WP Super Cache o W3 Total Cache
  • La cache de tu navegador
  • La cache de servicios como Cloudflare
  • La cache de tu servidor, como puede ser Opcache, Varnish o APC

Solución: deberíamos de borrar todas estas caches si no queremos tener problemas con el editor visual de WordPress, las imágenes o incluso en la zona administración del propio WordPress. Si no sabes como hacerlo, sobre todo en el caso de las caches del servidor, consulta con tu servicio de hosting o déjame un comentario y te intento ayudar.

¡Ojo! En el caso de la cache de tu servidor, puede provocar incluso que parezca que WordPress no ha sido actualizado (cuando realmente si ha sido así).

Todo esto se debe a que en WordPress 4.5 se han actualizado muchos scripts a nuevas versiones: jQuery 1.12.3, jQuery Migrate 1.4.0, Backbone 1.2.3, and Underscore 1.8.3, por lo que estos servicios de cache pueden tener almacenadas las versiones antiguas y provocar errores en WordPress.

¡Ojo! Muchas veces los bloqueadores de anuncios del navegador como Adblock pueden provocar que el editor visual de tu post no aparezca. La solución es desactivar este bloqueador para tu página web.

Solucionando los principales errores al actualizar a WordPress 4.5: cuidado con los plugins

Este consejo siempre se da. Es posible que algún plugin que tengas instalado no sea compatible con esta versión y provoque que no puedas ni acceder a la zona de administración de tu blog.

Solución: Entre mediante FTP a tu servidor y borra la carpeta de dicho plugin. Puedes consultar la siguiente guía oficial: “How to deactivate all plugins when you can’t log in to wp-admin”

¡Ojo! Parece que hay problemas con los siguientes plugins:

  • Visual Composer: hay que actualizar a la versión 4.11.1+
  • Custom Facebook Feeds: Destroza Javascript
  • Jetpack: Tienes que estar conectado a WordPress.com o puede fallar la carga de imágenes con Photon.

Solucionando los principales errores al actualizar a WordPress 4.5: cuidado con tu tema

Otro problema se puede presentar con el tema que tengas instalado. Es posible que algunos de los cambios en el código de la nueva versión de WordPress no sean compatibles con tu antiguo tema porque el desarrollador no lo ha actualizado.

Solución: Tienes que cambiar de tema. Puedes probar con alguno de los temas oficiales como Twenty Fifteen. Debes borrar o cambiar de nombre la carpeta de tu antiguo tema accediendo a tu servidor mediante FTP

¿Y si todo falla al actualizar?

Pues vas a tener que actualizar de manera manual WordPress, como se hacía en los primeros tiempos de este CMS, subiendo mediante FTP todos los archivos a tu servidor (no borres el directorio wp-content o el archivo wp-config.php

Fuente: wordpress.org

  • Yo creo que esta versión de WordPress es la que más problemas nos trae a todos

    • A mi me esta dando problemas la versión de la app de wordpress para escritorio en el Mac…